1) One of the following:

a. FSX SP2

b. FSX Acceleration

c. FSX Gold

d. Prepar3D 1.4+, 2.0+, 3.0+, 4.0+, 4.1+, 4.2+, 4.3+

e. FSX Steam Edition

2) PMDG NGX, 77X, 747 QOS II or MD11

3) Internet access

4) Direct X compatible video card

5) A PC running Windows Vista, 7, 8 or 10.

6) .NET Framework version 3.5 and 4.6.2+ with all Windows updates applied.

Cookies make it easier for us to provide you with our services. With the usage of our services you permit us to use cookies.
More information Ok Decline