11th September: A new version of the GoFlight Interface Tool for FS2020 is now available. THIS IS A VERY BASIC VERSION WITH LIMITED FUNCTIONALITY. IT IS A WORK IN PROGRESS.
29th April: A new version of the GoFlight Interface Tool for X-Plane is now available (2.0.16.3).
18th April: A new version of the GoFlight Interface Tool for P3Dv4 (3.8.0.0) is now available.
2nd August: A new version of the Engravity CDU PMDG Interface (2.0.5.0) is now available. For P3Dv4 64Bit only.
*** PLEASE NOTE ***
Your forum account is not the same as the account used in the shop. They are completely separate accounts.
There are full online user guides for all products under the Support menu of this website!
Most of the commonly reported issues and questions are answered in the Frequently Asked Questions (FAQ) option under the Support menu of this website.

GIT crashed after Start P3Dv5

Hello, I need help Git 3.8.0 crashed after start : GoFlight Worker Thread failed.

08:01:17 GoFlight Connection Starting.....
08:01:17 SimConnect Connection Starting.....
08:01:17 SimConnect Message Processing Started
08:01:17 GoFlight Worker Thread Failed: Die Eingabezeichenfolge hat das falsche Format.
08:01:17 SimConnect Connection Started
08:01:17 Aircraft Connection Starting.....
08:01:18 PMDG SDK option is OK in Prepar3D v5
08:01:18 SimConnect: Event Received: Aircraft Type Changed
08:01:18 SimConnect: Event Received: SIM, 1
08:01:18 SimConnect: Event Received: PAUSE, 0
08:01:18 SimConnect Message Processing Finished
08:01:18 SimConnect Connection Starting.....
08:01:19 SimConnect Message Processing Started
08:01:20 SimConnect Connection Started
08:01:20 Aircraft Connection Starting.....
08:01:20 SimConnect: Event Received: Aircraft Loaded/Flight Loaded
08:01:20 SimConnect: Event Received: SIM, 1
08:01:20 SimConnect: Event Received: PAUSE, 0
08:01:23 WinSock: Connected To localhost On Port 27015!
08:01:23 LUA Processor: Started!

Thanks for help.
Florian

Comments

  • And I run into the next Problems with the outdated (but actual 2.28.0-2) GoFlight Driver it caused BSOD in Win10pro, I have tested the driver now with the Windows PowerSheel Console and on every stress test the PC crashed.
  • I have GIT version 3.8.0.0 and it works great in P3Dv4 but not in P3Dv5. in v5 I have no IAS/MACH indication and the led's are off. The dials I can rotate and in rotates in the cockpit but not on the MCP. Should I download the latest version ?? (which is 3.8.0.0 ?)

    Henk.
  • If the GoFlight drivers are crashing, then something is up with your PC/Windows Config. GIT relies on the GoFlight drivers working OK. They work fine on my Windows 10 Pro PC.

    Best wishes
    Steve
  • Solved ! Sorry.
  • Hello Steve, thanks for the replay.

    Can this is an issue with the Win10 admin rights ?
  • Not sure, but the GoFlight software does need to run with admin rights.
  • edited July 9
    Hello Steve, I m looking deeper in that last night and found something strange.
    Looking inside the GoFlight CFG there are not all Module listet but when I am open the GF Config with Admin rights there are all there.
    So now I have copy a GF CFG from my P3Dv4 NAS Backup for a test into it and volar it runs :smiley: but NO Numbers on the MCP with PMDG NGXu -> next step copy again from the Backup the GIT Settings and Test Again.

    After a PC Restart it is broken again.

    Any Ideas ?

    Thank you Steve again for Support on that piece of Soft and Hardwae.
  • See the FAQ entry titled "My MCP PRO or MCP Advanced is not updating its display (just showing zeroes or dashes)" here: https://www.pollypotsoftware.org.uk/support/user-guide/user-guide-git/16-installation/70-faq-goflight-interface-tool.html
Sign In or Register to comment.